Dave Heavy Industries - A journal of tech-findings and ramblings

28 May 2020

Cisco AussieBB FTTC NBN Config

We had AussieBB install an FTTC service to our premises, it took a little bit of poking to get going, here’s what we found.

Note: we put the NTD into our switch on it’s own vlan (999) so that we could send it elsewhere without having to pull cables out. Another Note: FTTC is shared between up to 4 premises, if you are the only one on the FTTC unit, it might take 5 mins to boot-up - this is because your NTD powers up the FTTC unit (reverse phantom power) and it takes a bit to boot. If it does not come up immediately, don’t panic, make a coffee and come back.

public interface - we had a 100mbit/40mbit service. it comes into the router tagged on vlan 999.

!
interface GigabitEthernet0/0.999
 description outbound
 bandwidth 100000
 bandwidth receive 40000
 encapsulation dot1Q 999
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
end

if you don’t do that with your switch, your interface would look like this instead.

!
interface GigabitEthernet0/0
 description outbound
 bandwidth 100000
 bandwidth receive 40000
 ip address dhcp
 ip nat outside
 ip virtual-reassembly in
end

simples!

default-route… this is something to note, it comes in via DHCP.. so you need this command

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0.999 dhcp

your lan interface should look like this

interface GigabitEthernet0/1
 description LAN
 ip address 192.168.0.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
end

and your nat stuff should look like this (replace 0/0.999 with your actual interface)

ip access-list extended nat-fttc
  permit ip 192.168.0.0 0.0.0.255 any
ip nat inside source list nat-fttc interface GigabitEthernet0/0.999 overload

and finally - a port forward for good measure (add as many as you want (111.xxx.yyy.zzz is your PUBLIC IP, this forwards port 443 through to 192.168.0.1 internally)

ip nat inside source static tcp 192.168.0.1 443 111.xxx.yyy.zzz 443 extendable

comments powered by Disqus