Dave Heavy Industries Dave Heavy Industries – blog

7Feb/119

Cisco 877 TPG Config

Well, TPG uses PPPoE rather than PPPoA like most ISP, and there were a few issues with the MSS before my TPG was working correctly. Now it runs like a dream, no complaints at all.

I'll post the relevant sections below

config working on IOS 12.4(24)T3

replace [username] with your TPG username and [password] with your TPG password.

hostname router
ip dhcp pool general
network 10.10.10.0 255.255.255.0
dns-server 10.10.10.1
default-router 10.10.10.1
domain-name router.local
!
ip dns server
ip domain name router.local
ip name-server 203.12.160.35
ip name-server 203.12.160.36
ip name-server 203.12.160.37
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
switchport access vlan 1
!
interface FastEthernet1
switchport access vlan 1
!
interface FastEthernet2
switchport access vlan 1
!
interface FastEthernet3
switchport access vlan 1
!
interface Vlan1
description --- INSIDE INTERFACE ---
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer1
description --- OUTSIDE INTERFACE ---
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username [USERNAME]@tpg.com.au password 0 [PASSWORD]
!
ip access-list extended nat
permit ip 10.10.10.0 0.0.0.255 any
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
ip dns server
ip nat inside source list nat interface Dialer1 overload

[facebook_ilike]

Thanks Narkotix for correcting a mistake with the dns server config.

Tagged as: , , , , Leave a comment
Comments (9) Trackbacks (0)
  1. Hi Dave,
    I am a bit of a newbie.

    Is there a link you cant point me to that outlines the process of downloading to a router a config and activating and saving that config on the router?

    Thanks heaps

  2. Thanks for a working script – saved me lots of time debugging TPG’s configs.

  3. Thanks for a great config. I know a couple of mates use it.

    Unfortunately my 877 had a dead ADSL port. The CD light just flashes, but it doesn’t sync.

    Because of this, I was thinking about using a cheapy adsl modem in bridged mode, then using on of the FE ports connected to my 877.

    Is it possible to have the PPPoE config and all that other stuff outside if the dialer interface? Or is that the only WAN interface that I would be able to implement the commands on?

    • sure can… the basics of it are to assign a vlan to an fe port (connected to the dsl modem), and assign a pppoe dialer to that vlan.
      i.e.
      vlan 5
      name pppoevl
      int fe3
      switchport access vlan 5
      int vlan 5
      ip address dhcp !not really needed, but will help in configuring your dsl modem
      pppoe enable group global
      pppoe-client dial-pool-number 1

    • oh – and you know you can purchase a smartnet contract for it and claim a month later right?

      • I never even thought of that! Where do you get your contracts from?… Weighing it up, it might be cheaper to buy another 877 off ebay again.

        Thanks for replying!

  4. Hi Dave,

    I’m new to cisco products and have used the above config and the dialer is getting the static tpg address so it’s connected and I can ping google from the console but after I then plug in a laptop and get the deco address I can not get to the Internet.

    The tracert to google gets as far as 10.10.10.1 and then stops there how do I get this to work?

    Any help would be massively appreciated this is my third day at it and your advice has been the most helpful sofar.

    Regards
    Dan


Leave a comment

No trackbacks yet.